Delphi/C++ Builderの不正なBMPファイルの脆弱性を修正するファイル

Delphi XE7/C++Builder XE7以前のバージョンに、BMPファイルの処理にバッファオーバーフローの脆弱性が見つかりました。
(JVNVU#97910946: Embarcadero Delphi と C++Builder の VCL にバッファオーバーフローの脆弱性)

各バージョンの修正方法は次の通り

コメント

  1. これ、困りますね…。
    XE5以前だと、Pro以上のエディションでなければ、修正出来ない…。
    ソースコード無しのStarterは、買い替えるしか無いって事ですね。
    (ケチクサい話ですけど…^_^;)

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください