FlutterでFailed to find gems [“ffi”]エラー

flutterでiOSアプリをビルドすると”Ignoring ffi-1.15.5 because its extensions are not built.”エラーが発生した。

Error output from CocoaPods:
↳
    Ignoring ffi-1.15.5 because its extensions are not built. Try: gem pristine ffi --version 1.15.5

エラーメッセージにあるコマンドを実行したら、エラーになった。

% sudo gem pristine ffi --version 1.15.5
Password:
ERROR:  While executing gem ... (Gem::Exception)
    Failed to find gems ["ffi"] = 1.15.5

以下のコマンドを実行してインストールした。

% sudo gem install ffi --version 1.15.5

Building native extensions. This could take a while...
Successfully installed ffi-1.15.5
Parsing documentation for ffi-1.15.5
Installing ri documentation for ffi-1.15.5
Done installing documentation for ffi after 9 seconds
1 gem installed

コメントを残す

メールアドレスが公開されることはありません。

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください