古いバージョンのCocoaPodsをインストールするには

CocoaPodsはバージョン1.0.0からpodfileの書き方が変更された。
プロジェクトで使用しているpodfileが古いバージョン場合、古いCocoaPodsが必要になることもある。

インストールされているCocoaPodsのバージョンを確認する。

pod --version

CocoaPodsをアンインストールする。

sudo gem uninstall cocoapods

バージョンを指定して、CocoaPodsをインストールする。
# ここではバージョン0.39.0をインストールする。

sudo gem install -v 0.39.0 cocoapods

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です